Knowledge Base

Requirements

This is only verified on Ubuntu 18.04 and requires 64bit version.

Minimum Requirements: resolution of 1920x1080 for your primary screen, and graphics card with drivers able to run version 4 of OpenGL shaders. Suggest installing the latest graphic drivers and recommend the system uses an SSD Drive.

You will need FFmpeg installed. sudo apt update;  sudo apt-get install ffmpeg;

If you have trouble importing a file (e.g. mp4), you could review:
https://help.ubuntu.com/community/RestrictedFormats
which amounts to trying this: sudo apt-get install ubuntu-restricted-extras

Some OS distributions don't have the certain libraries installed by default, these should be detected missing and listed on the splash screen for you to install via your package manager. The deployment is not fool proof yet, therefore for reference, as well as ffmpeg,  IQSynth relies on the following libraries: sqlite3, libfreetype, libpng, libjpeg.

Known issues are listed below

If you can not find an answer, wish to report an issue or ask a question, please email contact@iqsynth for support.

Latest release notes and download here.

Currently working on: Midi Review

Known Issues are listed below (simple list at this time).

High Priority

1. Reworking APC mapping

Mid Priority

1. Text entry sometimes does not accept key presses unless cursor is left over control

Low Priority

1. New takes are not available for instances of a clip already in the rack (workaround: replace instances to use new takes)

General Notes:

As of 29th Aug 2019, v 0.15.0 updated plugin system and released all available plugins

As of 30th Jan 2019, v 0.10.5 updated plugin collection, should run better on NIVIDA setups .

As of18th Dec 2018, v 0.9.17 includes a security update for the SQLite component.

As of 24 Sept 2018, v 0.9.4 no longer requires libGLEW, this was causing the application to stall at startup.

To Do List (no particular order, you could contact and vote for priority)

  1. General tidy-up and optimizations (on going)
  2. Create and add menus system, and drop down controls
  3. Plugin installs via front end
  4. Plugin API Documentation
  5. Investigate AppImage deployments

 

Q & A

Q: The application stops with the splash screen saying my version of the OpenGL Shading Language is not high enough, why?

A: iQSynth relies on the response from the drivers when querying the available shading language version. You can check whats available by installing glxinfo, then run the following command at a terminal:

glxinfo | grep shading

It has been reported that it is possible to have a different shading language versions listed and the OpenGL check in iQSynth performed by glGetString(GL_SHADING_LANGUAGE_VERSION)  is returning a lower version then required.


IQSynth Revision Notes

A list of all the notes from all versions is provided below.

0.10.2

Fixed mouse capture when application over desktop menu and side bar
Declared internal shaders to minimum version so they compile and run on NVIDIA cards

0.10.1

Removed glew warning that was stopping start up on fresh install
-- glew requirement was removed some time ago

0.10.0

Added Auxiliary FX system
Workbench no longer pauses when not in focus
Fixed select cue rack bug

0.9.17

Updated SQLite component with security update

0.9.16

Fixed segfault on shutdown
Fixed Hot Cue selection bug
Minor change to order of section tabs